Usar PHP 5.x será peligroso en 2 meses

WordPress, Joomla, Drupal y muchos otros CMS fueron escritos en un lenguaje de programación PHP. La versión 5 de PHP está a punto de llegar al final de su vida útil y dejará de recibir actualizaciones de seguridad en dos meses. Muchos sitios web permanecen en la versión 5.6 o anterior. Lo que los hace un objetivo muy interesante para los hackers.  Una vez que el soporte para PHP 5 termina en dos meses, estos sitios se encuentran en una posición precaria y en peligro ante las vulnerabilidades de PHP 5 sin actualizaciones de seguridad.

¿Que es el fin de vida “end of life”, en Software?

Cuando un producto de software llega a su “fin de vida”, significa que los desarrolladores no le van a dar mantenimiento. Y eso es algo realmente malo. Por que cualquier problema de seguridad que surja en el futuro , se quedará sin ser resuelto. 

Por lo general, en productos con un continuo desarrollo como PHP, las nuevas versiones se suceden con bastante velocidad, y el equipo de desarrollo se compromente con cada version por un tiempo limitado. 

Una vez transcurrido ese tiempo, el equipo de desarrollo sugiere que la comunidad de usuarios actualice a una versión más nueva del mismo software, que generalmente hace las cosas mejor que las versiones anteriores y es totalmente compatible.

¿Cuando finaliza el mantenimiento de la version 5 de PHP?

El fin de esta version esta ya muy cerca y será el 1 de Enero del 2019. En este momento la unica version soportada es la 5.6, y esta esta a punto de concluir.

La siguiente tabla indica los plazos de mantenimiento programado para las versiones actuales de php:

 

 

 

 

 

¿Por qué deberia actualizarme a la version 7 de PHP?

Como mencionamos arriba, los problemas de seguridad que aparezcan a partir del 1 de Enero del 2019, se quedarán sin solucionar, lo que pondra en peligro tu pagina web.

Ademas, PHP 7 tiene mejoras importantes sobre php 5. Tu pagina funcionara mas rapidamente sobre php 7. 

 

¿Donde puedo ver la versión que estoy usando actualmente?

Desde tu panel de control. En la sección “Administrador MultiPHP”.

 

¿Como puedo cambiar mi version de php?

Puedes revisar nuestro tutorial que explica el proceso para cambiar la version de php que usa tu cuenta de hosting

¿Que version de PHP 7 deberia usar?

Lo idea, es que uses la ultima version disponible, en este momento la version 7.2. Esta es la version que ofrece mas garatias y un soporte a futuro mas largo. 

No es recomendable actualizar a la version 7.0, ya que el fin de vida de esta version igulamente se aproxima con velocidad.

 

 

Prueba nuestro servicio gratis

Si aun no conoces nuestro servicio, pruebalo Gratis. Estamos seguros que te encantará